Back to overview
Degraded

Netlify CDN Slowdowns

Mar 20, 2026 at 9:15pm UTC
Affected services
Netlify CDN
Netlify CDN

Resolved
Mar 20, 2026 at 9:22pm UTC

Observed that Netlify CDN slowdowns have improved.

Created
Mar 20, 2026 at 9:15pm UTC

Netlify CDN monitors for "https://admin.mylesandlekhini.ca" is experiencing slowdowns and fetch errors.